POJ 2785:4 Values whose Sum is 0 (双向BFS)

4 Values whose Sum is 0

 

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 20020 Accepted: 5977
Case Time Limit: 5000MS

 

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

 

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

 

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

 

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

 

Sample Output

5

 

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

 

题意:求在四组数中各挑选一个满足a+b+c+d==0的个数。

 

直接使用BFS时间复杂度是O(n^4),显然会超时,我们可以把整个四组数据分成两组,然后就是对两组数据分别BFS,最终统计结果,这样便把时间复杂度降低到了O(n^2),很容易就可以过啦~

 

AC代码:

#include<cstdio>
#include<math.h>
#include<iostream>
#include<algorithm>
#define max(a,b) (a>b?a:b)
using namespace std;
__int64 a[4005],b[4005],c[4005],d[4005];
__int64 cd[4005*4005];
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
        scanf("%I64d%I64d%I64d%I64d",a+i,b+i,c+i,d+i);
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            cd[i*n+j]=c[i]+d[j];
    sort(cd,cd+n*n);
    __int64 ans=0;
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
        {
            __int64 ab=-(a[i]+b[j]);
            ans+=upper_bound(cd,cd+n*n,ab)-lower_bound(cd,cd+n*n,ab);
        }
    printf("%I64d\n",ans);
    return 0;
}

我想对千千说~